Schnittstellen, API & App

Exchange, Jira, API und Co. - alles über unsere Schnittstellen erfährst Du in diesem Abschnitt.

Excel Auswertungen per API

API Excel Zugriff mit Windows (via Daten abrufen)

Prinzipiell gibt es für Windows Benutzer zwei Varianten um per Excel auf die HQ-API zuzugreifen:

  1. Zugriff über die Excel Funktion Daten abrufen
  2. Zugriff per Excel Add-In

Um die Daten direkt über Excel abzurufen musst du auf den Reiter "Daten" - "Daten abrufen" - "Aus anderen Quellen" - "Leere Abfrage" gehen.

Screen_1.png

Nun erscheint ein Fenster auf dem zu auf "Erweiterter Editor" klickst.

Screen_2.png

In nächsten Fenster muss die folgende Abfragen eingegeben werden (Einfach per Copy & Paste einfügen):

let 
    BaseUrl         = "https://api.hqlabs.de/v1/<<<HIER OBJEKT EINFÜGEN>>>?",
    Token           = "<<<HIER API TOKEN EINFÜGEN>>>",
    EntitiesPerPage = 1000,
 
    GetJson = (Url) =>
        let Options = [Headers=[ #"Authorization" = "Bearer " & Token ]],
            RawData = Web.Contents(Url, Options),
            Json    = Json.Document(RawData)
        in  Json,
 
    GetEntityCount = () =>
        let Url   = BaseUrl & "$count=true&$top=0",
            Json  = GetJson(Url),
            Count = Json[#"@odata.count"]
        in  Count,
 
    GetPage = (Index) =>
        let Skip  = "$skip=" & Text.From(Index * EntitiesPerPage),
            Top   = "$top=" & Text.From(EntitiesPerPage),
            Url   = BaseUrl & Skip & "&" & Top,
            Json  = GetJson(Url),
            Value = Json[#"value"]
        in  Value,
 
    EntityCount = List.Max({ EntitiesPerPage, GetEntityCount() }),
    PageCount   = Number.RoundUp(EntityCount / EntitiesPerPage),
    PageIndices = { 0 .. PageCount - 1 },
    Pages       = List.Transform(PageIndices, each GetPage(_)),
    Entities    = List.Union(Pages),
    Table       = Table.FromList(Entities, Splitter.SplitByNothing(), null, null, ExtraValues.Error)
in
    Table

 

Nun sind noch 2 kleine Anpassungen notwendig. Erstens, musst du dich authentifizieren. Dies passiert über den “API Token”, den du dir direkt aus dem HQ holen kannst. Unter Admin/ API Clients ist dieser Token zu finden, der nun in unser Skript statt <<<HIER API TOKEN EINFÜGEN>>> einsetzen, eingefügt wird.

Nun musst dur der API noch sagen, welche Objekte eigentlich abrufen werden sollen (z.B. Leads, Unternehmen, Projekte usw.). Das gewünschte Objekt fügst du dann in den Code anstelle von <<<HIER OBJEKT EINFÜGEN>>> ein. Die Liste aller verfügbaren Objekte findest du unter https://developer.helloHQ.io 

Screen_3.png

Wenn Du nun auf "Fertig" klickst musst Du noch die Spalten erweitern.

Screen_4.png

Anschließend kann die Abfrage benannt werden und per "Schließen & laden" die Daten in die Excel übernommen werden.

Screen_5.png

Über den Reiter "Daten" - "Alle aktualisieren" können ab jetzt immer die aktuellen Daten aus dem HQ abgerufen werden.

Screen_6.png

Nun kannst Du mit den Daten in Excel weiterarbeiten und z.B. Pivot-Tabellen und Grafiken zur Auswertung erstellen. Natürlich kannst du hierfür auch mehrere Abfragen pro Excel hinzufügen, z.B. um Projekte und Unternehmen zu verbinden.

 

ACHTUNG: Wenn du eine ältere Version von Excel als 2016 verwendest musst du das kostenlose Excel Add-In PowerQuery von Microsoft installieren. 

API Excel Zugriff mit Windows (via Excel Add-In)

Prinzipiell gibt es für Windows Benutzer zwei Varianten um per Excel auf die HQ-API zuzugreifen:

  1. Zugriff per Excel Add-In
  2. Zugriff über die Excel Funktion Daten abrufen

ACHTUNG: Das Add-In funktioniert erst ab der Excel Version 2016 (oder höher)

Um Daten aus dem HQ via API abzurufen, kannst Du dir HQ als Excel Add-In installieren. Dazu musst zunächst die folgende Datei heruntergeladen werden:

hq-addin-manifest.xml

Diese muss auf dem PC in einem Ordner abgelegt werden in dem die Datei dauerhaft gespeichert werden kann (Achtung: Der Name des Ordners darf keine Leerzeichen enthalten). Anschließend muss die Datei per Rechtsklick / "Zugriff gewähren auf" / "Bestimmte Personen" an den Benutzer des PCs freigegeben werden.

Screenshot_1.png

Nun wird ein Link angezeigt, der per Rechtsklick kopiert werden muss. 

Screenshot_2.png

Nun muss dieser Link in Excel hinterlegt werden. Dazu geht man in Excel auf "Datei" - "Optionen" - "Trust Center" - "Einstellungen für das Trust Center". 

Screenshot_3.png

Im neuen Fenster muss die Kategorie "Kataloge vertrauenswürdiger Add-Ins" ausgewählt werden und die URL unter "Kataog-URL" eingegeben werden (Achtung: Alle "/" müssen durch "\" ausgetauscht werden), sowie alle Inhalte nach dem Ordnernamen bzw. vor dem doppelten "\\" müssen entfernt werden (Siehe Screenshot). Klicke nun auf "Katalog hinzufügen" und wähle "Im Menü anzeigen". Nun auf "ok" klicken und Excel neu starten. 

Screenshot_4.png

Das Add-In kann nun in Excel über "Einfügen" "Meine Add-Ins" geladen werden.

Screenshot_5.png

Klicke nun auf "Geteilter Ordner", wähle die Option "HQ-API-ACCESS" aus und klicke auf "Hinzufügen".

Screenshot_6.png

Nun steht die HQ API per Button in Excel zur Verfügung.

Screenshot_7.png

Nun muss nur der API Token (zu finden im HQ unter Admin / API-Client eingegeben und auf "Tabelle hinzufügen" geklickt werden. Nun werden die Daten aus der ausgewählten Tabelle in die Excel geladen. Über den Button "Daten aktualisieren" können immer die neusten Daten aus dem HQ abgerufen werden.

Screenshot_8.png

 

ACHTUNG: Damit die Datei auch mit größeren Datenmengen umgehen kann, muss die "Berechnungsoption" (in Excel unter Formeln) auf "manuell gesetzt werden. Das Plugin führt diese Berechnung automatisch am Ende durch.

Screen.png

API Excel Zugriff mit MacOS (via Excel Add-In)

ACHTUNG: Das Add-In funktioniert erst ab der Excel Version 2016 (oder höher)

In Microsoft Excel für MacOS kannst du ebenfalls die HQ-API einbinden. Folge dafür einfach folgenden Schritten.

1. Installer herunterladen: https://hqlabs.zendesk.com/hc/article_attachments/360000272080/HQ_API_Excel_Plugin.zip

2. ZIP entpacken und Datei ausführen

(WICHTIG: Rechtsklick auf die .mpkg-Datei und dann "Öffnen" auswählen)

Screen_Shot_2018-08-27_at_18.13.07.png

3. Anweisungen im Installer folgen und installieren

Screen_Shot_2018-08-27_at_18.14.02.png

4. Microsoft Excel starten, zum Reiter "Einfügen" wechseln und bei "Meine Add-ins" auf den kleinen Pfeil klicken und das HQ-API-Add-in starten

Screen_Shot_2018-08-27_at_18.36.38.png

5. Auf API Access laden klicken und einen API-Token hinterlegen. API-Token erhältst du direkt aus deinem HQ unter Admin / API Clients.

Screen_Shot_2018-08-27_at_18.38.47.png

6. Um eine Entität wie Projekte, Unternehmen, Benutzer usw. aus dem HQ zu laden, wählst du zunächst die gewünschte Tabelle aus und klickst anschließend auf "Tabelle einfügen".

Excel fügt anschließend die Tabelle als neues Tabellenblatt ein, das in gewohnter Weise verwendet kann.

Screen_Shot_2018-08-27_at_18.40.41.png 

Um Daten zu aktualisieren reicht eine Kick auf "Daten aktualisieren".

Welche Entitäten aus der API geladen werden können, kannst du auch unter developer.helloHQ.io herausfinden.

ACHTUNG: Damit die Datei auch mit größeren Datenmengen umgehen kann, muss die "Berechnungsoption" (in Excel unter Formeln) auf "manuell gesetzt werden. Das Plugin führt diese Berechnung automatisch am Ende durch.

image.png

API Excel Zugriff - Daten aktualisieren (via Excel Add-In)

Die Abfrage der aktuellen Daten aus dem HQ ist sehr einfach. Dazu muss einfach das Plugin aktiviert werden und auf den Button "Daten aktualisieren" gerückt werden. 

Screen_1.jpg

Sind die Daten dann nicht aktuell muss ggf. die Berechnung manuell angestoßen werden (dies sollte eigentlich durch das Plugin passieren). Dazu einfach auf "Formeln" und "Neu berechnen" (oder F9) klicken. 

Screen_3.jpg

Wenn mit einer Pivot gearbeitet wird muss die Pivot selbst auch aktualisiert werden. Dazu einfach in die Pivot Tabelle klicken, auf "Analysieren" gehen und "Aktualisieren" klicken.

Screen_2.jpg

 

Daten aus dem HQ mit Power BI auswerten

Mit dem HQ haben unsere Kunden den gesamten Prozess ihrer Agentur an einer zentralen Stelle im Griff. Natürlich bietet diese Integration grenzenlose Möglichkeiten für gutes Controlling und Auswertungen aller Art. Mit unseren integrierten Controlling-Modulen bietet das HQ bereits eine Vielzahl unterschiedlicher Berichts- und Auswertungsmöglichkeiten “Out-of-the-Box”. Die konkreten Anforderungen an das Unternehmenscontrolling unserer Kunden sind aber so vielfältig, wie es die Agenturlandschaft ist. Natürlich können wir nicht jede noch so ausgefallene Berichtsidee im HQ umsetzen – aber wir können die passenden Daten bereit stellen.

Mit Power BI bietet Microsoft seit einiger Zeit ein sehr mächtiges – und kostenfreies – Controllingwerkzeug an, das Daten aus den unterschiedlichsten Quellen aggregieren und aufbereiten kann. Aufgrund seiner Nähe zu Excel sind die zu verwendenden DAX-Formeln (DAX von Data-Analytics-Expressions, nicht von Deutscher Aktien Index) vielen Office-Nutzern außerdem schon bekannt.

Einer der wichtigsten Schritte bei der Erstellung von Berichten in Power BI ist das richtige Anbinden der Datenquelle. Klassiker wie Excel-Tabellen oder SQL-Datenbanken sind kein Problem, bei komplexen Datenstrukturen wie sie dem HQ zugrunde liegen, ist etwas mehr Denkarbeit notwendig. Hier kommt unsere offene REST-API (Daten- und Programmierschnittstelle) zur Hilfe.

Wir verwenden den verbreiteten OData Standard zur Übertragung von Daten aus und in das HQ. Dieser Standard wird auch von Power BI unterstützt und erleichtert uns das Leben. Los geht es also:

Als erstes öffnen wir Power BI und beginnen, indem wir über die Schaltfläche “Daten abrufen” eine neue Datenquelle anlegen.

ezgif-5-85a204e84d.jpg

Wir wählen “Sonstige” –> “Leere Abfrage” aus der langen Liste der Verfügbaren Datenquellen aus.

Screen2.jpg

Ein leeres Abfragefenster wird geöffnet. Um uns mit der HQ-API zu verbinden, öffnen wir den erweiterten Editor.

Screen3.jpg

Nun folgt der etwas technischere Teil unserer Übung. Unser Entwickler Mark hat Gott sei Dank etwas Vorarbeit für uns geleistet und das technische Prinzip zur Ansprache der HQ-API aus Power BI für uns geknackt. Die technischen Details hat er für Interessierte hier zusammen gefasst. Wir werden es an dieser Stelle etwas vereinfachen.

Der folgende Code ruft Daten aus dem HQ ab. Um dies in Power BI zu verwenden, kopieren wir einfach den vollständigen Code in unser leeres “erweiterter Editor” Fenster in Power BI.

let 
    BaseUrl         = "https://api.hqlabs.de/v1/<<<HIER OBJEKT EINFÜGEN>>>?",
    Token           = "<<<HIER API TOKEN EINFÜGEN>>>",
    EntitiesPerPage = 1000,
 
    GetJson = (Url) =>
        let Options = [Headers=[ #"Authorization" = "Bearer " & Token ]],
            RawData = Web.Contents(Url, Options),
            Json    = Json.Document(RawData)
        in  Json,
 
    GetEntityCount = () =>
        let Url   = BaseUrl & "$count=true&$top=0",
            Json  = GetJson(Url),
            Count = Json[#"@odata.count"]
        in  Count,
 
    GetPage = (Index) =>
        let Skip  = "$skip=" & Text.From(Index * EntitiesPerPage),
            Top   = "$top=" & Text.From(EntitiesPerPage),
            Url   = BaseUrl & Skip & "&" & Top,
            Json  = GetJson(Url),
            Value = Json[#"value"]
        in  Value,
 
    EntityCount = List.Max({ EntitiesPerPage, GetEntityCount() }),
    PageCount   = Number.RoundUp(EntityCount / EntitiesPerPage),
    PageIndices = { 0 .. PageCount - 1 },
    Pages       = List.Transform(PageIndices, each GetPage(_)),
    Entities    = List.Union(Pages),
    Table       = Table.FromList(Entities, Splitter.SplitByNothing(), null, null, ExtraValues.Error)
in
    Table

WICHTIG: Bei gewissen Entitäten, wie zum Beispiel Rechnungen oder Eingangsrechnungen, muss für den Wert 'EntitiesPerPage' statt 1000 eine 100 eingetragen werden, damit alle Daten angezeigt werden.

Nun sind noch 2 kleine Anpassungen notwendig. Erstens, müssen wir uns authentifizieren. Dies passiert über den “API Token”, den wir uns direkt aus unserem HQ holen. Unter Admin/ API Clients ist dieser Token zu finden, den wir nun in unser Skript statt <<<HIER API TOKEN EINFÜGEN>>> einsetzen.

Screen4.jpg

Nun müssen wir der API noch sagen, welche Objekte wir eigentlich abrufen wollen (z.B. Leads, Unternehmen, Projekte usw.). Das gewünschte Objekt fügen wir dann in unseren Code statt <<<HIER OBJEKT EINFÜGEN>>> ein. Die Liste aller verfügbaren Objekte finden wir auch unter developer.helloHQ.io , hier ein Auszug:

Screen5.jpg

Für unser Beispiel rufen wir als erstes alle Leads aus unserem Testsystem ab. nachdem wir das Code-Fenster geschlossen haben, erscheint als erstes folgende Fehlermeldung:

Screen6.jpg

Nach einem Klick auf “Anmeldeinformationen bearbeiten” wählen wir im folgenden Fenster die Option “Anonym” und bestätigen mit “Verbinden”.

Screen7.jpg

Jetzt werden die ersten Daten aus dem HQ abgerufen. Das folgende Fenster sieht allerdings noch nicht besonders spektakulär aus, so in etwa wie der folgende Screenshot. Wir müssen nun noch die richtigen Spalten unserer Daten einblenden. Das funktioniert mit einem Klick auf den kleinen “Expand” Button wie auf dem Screenshot gezeigt.

Screen8.jpg

Es öffnet sich ein kleines Fenster, in dem bereits die einzelnen Informationen unseres Datensatzes angezeigt werden. Theoretisch könnten wir nun auswählen, welche Spalten wir wirklich benötigen – wir können aber auch einfach alle aktiviert lassen.

Wichtig:
Das Häkchen “Ursprüngliche Spaltennamen…” unbedingt deaktivieren.

Screen9.jpg

Jetzt kommen wir der Sache schon sehr nahe, wir sehen schon die tatsächlichen Daten aus unserem HQ. Damit später z.B. ein Datum auch als solches erkannt wird und wir hübsche Zeitfilter etc. verwenden können, müssen wir die Spalten noch entsprechend markieren. Dazu einfach auf eine betroffene Spalte mit einer Datumsangabe oder z.B. einer Zahl klicken und auf “Datentyp erkennen” klicken. Nun wird automatisch der passende Datentyp zugewiesen.

Screen10.jpg

Zu guter Letzt geben wir unserer Abfrage noch einen passenden Namen (in diesem Fall “Leads”) und schließen den Editor.

Screen11.jpg

Das war der schwierige Teil! Jetzt stehen uns alle Daten unserer Abfrage in Power BI zur Verfügung. Per einfachem Drag & Drop bewegen wir die Spalten in unseren Bericht. Fertig ist das interaktive Dashboard. Ein Klick auf “Aktualisieren” holt die neuesten Daten aus dem HQ.

Screen12.jpg

Meistens wollen wir natürlich nicht “nur” Leads auswerten, sondern diese mit vielen anderen Informationen aus dem HQ verbinden. Das ist jetzt garkein Problem mehr – wir wiederholen einfach die oben gezeigten Schritte und rufen statt “Leads” jetzt eben noch “Unternehmen” oder “Projekte” oder irgendein anderes Objekt aus der API ab. Power BI bietet jede Menge Werkzeuge, um diese zu verknüpfen, Berechnungen anzustellen und auszuwerten. Inspiration bietet Microsoft direkt auf der Power-BI-Seite.

Natürlich könnt ihr euch wie immer gerne an uns wenden, wenn es um die Erstellung schöner Berichte geht – wir helfen mit Rat und Tat.

Custom Fields auswerten per API (via Daten abrufen)

Achtung: Diese Anleitung gilt nicht für den Fall das das Excel Plugin verwendet wird. Hier werden die CustomFields direkt mit den Daten abgerufen. 

Um Custom Fields (oder andere Felder, die sich laut developer.hellohq.io expanden lassen) in deiner Abfrage auszuwerten, musst du zunächst deinen Befehl erweitern. 

Am Beispiel einer Auswertung der Projekte bedeutet dies: 

Der Befehl https://api.hqlabs.de/v1/Projects? 

wird um die Custom Fields auszuwerten zu 

https://api.hqlabs.de/v1/Projects?$expand=CustomFields& 

Möchtest du nicht Custom Fields sondern andere Daten ausklappen, ersetzt du "CustomFields" einfach durch das jeweilige Objekt. Als nächstes klickst du auf fertig und kannst per Klick auf den Kopf  der entstehenden Spalte auswählen, welche Elemente dir angezeigt werden sollen. Den Marker bei "Ursprünglichen Spaltennamen als Präfix verwenden" solltest du an dieser Stelle nicht setzen. 

Nun erhältst du eine Liste, in der du die Spalte CustomFields siehst. Allerdings sind deren Werte als "List" angegeben. Nach einem Klick auf den Button oben rechts im Spaltenkopf wird dies zu "Record". Dann kannst du den Button erneut anklicken und im Pop-Up Value und Name selektieren. Hier selektierst du außerdem "Ursprünglichen Spaltennamen als  Präfix verwenden".

API_1.PNG

Allerdings stehen deine Datenfelder nun in der Spalte "CustomField.Name" untereinander. Um sie sinnvoll gegliedert anzuzeigen, markiere einmal die Spalte und klick im Reiter "Transformieren" auf den Button "Spalte pivotieren". 

API_2_marker.PNG

Im darauffolgenden Pop-Up selektierst du nun CustomFields.Value und unter Erweiterte Optionen "nicht aggregieren". 

API_3.PNG

Nun sollten dir deine Customfields und deren Inhalte tabellarisch angezeigt werden.

Alle anzeigen...

Apps

Gibt es eine Android App für das HQ?

Es gibt eine Zeiterfassungs-Android App fürs HQ, die du aus dem Google PlayStore herunterladen kannst. 

Vorsicht: Deine System Settings (wie zum Beispiel ein Verbot von Reportings auf geschlossene Projekte) werden von der App nicht berücksichtigt. 

1. Einrichtung

Du muss nach dem ersten Start der App mit deinem HQ und deinem Benutzer verbinden. Dazu wählst du 'Anmelden' aus und gibst als nächstes die URL eures HQs ein. Anschließend musst du dich mit deinem Benutzernamen und deinem Passwort anmelden und den Zugriff erlauben.

Schon ist die HQ App fertig eingerichtet.

2. Stoppuhr

Die Stoppuhr funktioniert wie das Stoppuhrwidget auf dem Dashboard im HQ. Nachdem du 'Stoppuhr starten' ausgewählt hast, wird dir eine Liste mit allen Projekten angezeigt. Hier wählst du dein Projekt und danach den Task aus, auf das du reporten möchtest. Sobald du das gemacht hast, läuft auch schon deine Zeiterfassung.

Wenn du auf 'Stoppuhr stoppen' drückst, hast du die Möglichkeit, den Task/Projekt zu wechseln oder die Zeit zu stoppen. Sobald du eins davon gemacht hast, wird das Reporting in dein HQ übertragen.

Tipp: Wenn du das System Setting "Reporting erzeugt auch ein Zeiterfassungseintrag" aktiviert hast, wird zu deinen Reportings aus der App auch ein Zeiterfassungseintrag erstellt.  

Android1.png

3. Reporten

Unter den Punkt 'Reporten' kannst du Reportings manuell anlegen. Die Auswahl der Projekte funktioniert dabei wie bei der Stoppuhr. Anschließend musst du nur noch die Dauer und das Arbeitsende eingeben und auf 'Jetzt reporten' klicken, um dein Reporting ins HQ zu übertragen.

Android2.png

4. Übersicht 

Hier findest du eine Übersicht all deiner Reportings, auch die die du nicht über die App erstellt hast. Diese Rportings sind nach Datum sortiert.

Wichtig: Dies ist nur eine Übersicht und die Reportings können in der App nicht bearbeitet werden. Die Bearbeitung der Reportings kannst du nur in deinem HQ vornehmen.

5. Einstellungen

In den Einstellungen kannst du ein dich aus der App ausloggen. Des Weiteren kannst du den Projektstatus der Projekte auswählen, die du angezeigt haben möchtest. Dazu wählst du 'Projektstatus' und aktivierst/deaktivierst deine gewünschten Status.

Android3.png

Wie installiere ich den MacReporter?

Den HQ MacReporter findest du ganz unten zum herunterladen.

Diese Datei kannst du entpacken und anschließend die App an einen Ort deiner Wahl verschieben (zB. in den Programme Ordner). Hier musst du einmal ein Rechtsklick auf die App machen und "Öffnen" auswählen. Dieser Schritt ist nur beim ersten öffnen der App notwenig.

MacReporter1.png

Anschließend musst du noch die eure System URL, deinen Benutzernamen und dein Passwort eingeben.

MacReporter2.png

Hier findest du die aktuellste Version des MacReporters:

Gibt es eine iOS App für das HQ?

Es gibt eine Zeiterfassungs iOS App fürs HQ, die du aus dem Apple AppStore herunterladen kannst. 

Vorsicht: Deine System Settings (wie zum Beispiel ein Verbot von Reportings auf geschlossene Projekte) werden von der App nicht berücksichtigt. 

1. Einrichtung

Du muss nach dem ersten Start der App mit deinem HQ und deinem Benutzer verbinden. Dazu wählst du 'Anmelden' aus und gibst als nächstes die URL eures HQs ein. Anschließend musst du dich mit deinem Benutzernamen und deinem Passwort anmelden und den Zugriff erlauben.

Schon ist die HQ App fertig eingerichtet.

2. Stoppuhr

Die Stoppuhr funktioniert wie das Stoppuhrwidget auf dem Dashboard im HQ. Nachdem du 'Stoppuhr starten' ausgewählt hast, wird dir eine Liste mit allen Projekten angezeigt. Hier wählst du dein Projekt und danach den Task aus, auf das du reporten möchtest. Sobald du das gemacht hast, läuft auch schon deine Zeiterfassung.

Wenn du auf 'Stoppuhr stoppen' drückst, hast du die Möglichkeit, den Task/Projekt zu wechseln oder die Zeit zu stoppen. Sobald du eins davon gemacht hast, wird das Reporting in dein HQ übertragen.

Tipp: Wenn du das System Setting "Reporting erzeugt auch ein Zeiterfassungseintrag" aktiviert hast, wird zu deinen Reportings aus der App auch ein Zeiterfassungseintrag erstellt.  

iOS-stoppuhr.png

3. Reporten

Unter den Punkt 'Reporten' kannst du Reportings manuell anlegen. Die Auswahl der Projekte funktioniert dabei wie bei der Stoppuhr. Anschließend musst du nur noch die Dauer und das Arbeitsende eingeben und auf 'Jetzt reporten' klicken, um dein Reporting ins HQ zu übertragen.

iOS-reporten.png

4. Übersicht 

Hier findest du eine Übersicht all deiner Reportings, auch die die du nicht über die App erstellt hast. Diese Rportings sind nach Datum sortiert.

Wichtig: Dies ist nur eine Übersicht und die Reportings können in der App nicht bearbeitet werden. Die Bearbeitung der Reportings kannst du nur in deinem HQ vornehmen.

5. Einstellungen

In den Einstellungen kannst du ein dich aus der App ausloggen. Des Weiteren kannst du den Projektstatus der Projekte auswählen, die du angezeigt haben möchtest. Dazu wählst du 'Projektstatus' und aktivierst/deaktivierst deine gewünschten Status.

Alle anzeigen...

Jira

JIRA - Fehler, Fehlermeldungen und Lösungen

Bei der Jira-Synchronisation müssen einige Faktoren beachtet werden. Dabei kann es manchmal passieren, dass etwas nicht ganz rund läuft. Für diese Fälle findest du hier die bekanntesten Fehler, ihre Ursachen und Lösungen. 

 

Dem Standardbearbeiter, dem dieser Vorgang zugewiesen wurde, kann dieser Vorgang NICHT ZUGEWIESEN werden ODER nicht zugewiesene Vorgänge sind abgeschaltet.

Der Bearbeiter des Vorgangs ist standardmäßig auf "Automatisch" gesetzt. Dies funktioniert allerdings mit der Schnittstelle nicht. Außerdem ist der Autor beim Erstellen eines Vorgangs nicht bearbeitbar und deshalb kommt es auch zu dieser Fehlermeldung. In einem Projekt kann ein Standardbearbeiter besetzt werden z.B auf den Projektleiter.

 

{"errorMessages":[],"errors":{"timetracking":"Nach der Arbeitsbeginn wird die Einstellung der Ursprünglichen Schätzung im Vorgängermodus nicht unterstützt."}}

Das Problem das die Tickets nicht korrekt synchronisiert werden liegt wahrscheinlich daran, dass du im Jira den Legacy-Modus für die Zeiterfassung aktiviert hast: https://community.atlassian.com/t5/Jira-questions/How-can-I-update-Original-Estimate-after-work-has-been-logged/qaq-p/120560 

Um diesen zu deaktivieren musst du in die Einstellungen -> Vorgänge -> Zeitverfolgung gehen, Globale Einstellungen bearbeiten und den Modus deaktivieren. Danach sollte der Sync funktionieren.

 

Das Jira-Kürzel verschwindet direkt nach dem Eintragen für eine Aufgabe wieder aus dem Projektplan im HQ und es wird kein Ticket in Jira erstellt.

Es existiert entweder kein Projekt in Jira oder der Sync-Nutzer hat keine ausreichenden Berechtigungen für dieses. Beides sollte geprüft und folglich angepasst werden, damit der Sync funktioniert.

 

{"errorMessages":["Der Wert '' existiert nicht für das Feld 'project'.

Es existiert entweder kein Projekt in Jira oder der Sync-Nutzer hat keine ausreichenden Berechtigungen für dieses. Beides sollte geprüft und folglich angepasst werden, damit der Sync funktioniert.

 

Das JIRA-Kürzel ist im HQ-Projekt hinterlegt und der User richtig angegeben, trotzdem werden Tickets nicht aus Jira gezogen.

Tickets werden erst als Task gezogen, wenn sie nach dem Verlinken des Jira-Projektes über das Kürzel einmal aktualisiert wurden (bearbeitet). Man kann alle Tickets eines Projektes in Jira über eine Mehrfachänderung aktualisieren. Dafür lässt man sich alle Vorgänge anzeigen und wählt dann über Tools die zu bearbeitenden aus.

 

{"description":"Field 'description' cannot be set. It is not on the appropriate screen, or unknown."}}

Der Account des HQ Users ist nicht im Projekt eingetragen oder nicht berechtigt. Du kannst ihn bei den Personen hinzufügen und seine Projektrolle über die Berechtigungen ermächtigen, Projekte zu durchsuchen und zu verwalten.

 

Falls dir eine Fehlermeldung angezeigt wird, die hier nicht aufgeführt ist, melde dich gerne bei unserem Support.


 

Welche JIRA Synchonisations-Modi gibt es? 

Es gibt grundsätzlich zwei Modi, mit denen Synchronisiert werden kann: HQ ist das führende System oder JIRA ist das führende System.

HQ führend

Wenn HQ das führende System ist, müssen die HQ Aufgaben in der Projektplanung mit einem JIRA Projekt verknüpft werden. Hierfür wird  die Spalte JIRA Projektkürzel in der Projektplanung mit dem Projektkürzel aus JIRA befüllt. Daraufhin wird in JIRA in dem ausgewählten Projekt ein korrespondierender Vorgang angelegt. Sobald in JIRA unter diesem Vorgang ein Untervorgang angelegt hat, wird dieser in der gleichen Hierarchie zurück zu HQ synchronisiert. 

Zusätzlich zu den Basisinformationen der Vorgänge werden zu Abrechnungszwecken auch alle Worklogs (=Zeiterfassungen) aus synchronisierten JIRA Vorgängen zu den verknüpften HQ Aufgaben synchronisiert. 

JIRA führend

Wenn JIRA das führende System ist, müssen JIRA Projekt und HQ Projekt verknüpft werden. Hierfür wird im HQ in der Stammdatenmaske der Projekte das Datenfeld JIRA-Projektkürzel mit dem JIRA-Projektkürzel befüllt. Ab diesem Moment wird jeder Vorgang, der in einem verknüpften JIRA Projekt angelegt wird, auch zu HQ synchronisiert. Workslogs werden erst synchronisiert, sobald der jeweilige JIRA Vorgang abgeschlossen ist. Dieser Modus dient nur der Abrechnung von Vorgängen in HQ - etwa in Support und Serviceverträgen. 

Zusätzlich zu den beiden Synchronisationsmodi kannst du auch direkt eine Aufgabe mit einem Vorgang verknüpfen. Hierfür musst du in der HQ Aufgabe einfach das Vorgangskürzel in das Feld HQ-Vorgang eintragen. Dies kann in der Projektplanung gemacht werden.
 
Tipp: Wenn einige Vorgänge nicht synchronisiert werden, überprüfe als erstes einmal deine HQ Benachrichtigungen. HQ teilt dir mit, wenn es bei der Synchronisation ein Problem gab.

Wie kann ich die JIRA Synchronisation einrichten?

Das HQ verfügt über eine JIRA-Schnittstelle, über die sich verschiedene Daten aus JIRA und HQ
synchronisieren lassen. Die Schnittstelle ermöglicht drei verschiedene Synchronisationsfunktionen:

Aufgaben aus der Projektplanung in HQ werden mit Tickets in JIRA synchronisiert

Um diese Funktion zu nutzen, musst du die Tasks in HQ mit einem Projekt in JIRA verknüpfen. Dazu musst du folgende Schritte machen:

  • In JIRA und HQ jeweils ein Projekt anlegen (die Namen müssen nicht identisch sein, da diese nicht mit synchronisiert werden)
  • In HQ kannst du nun alle die Tasks (und Unter- bzw. Folgetasks) im Projektplan angelegen, die für das Projekt gebraucht werden
  • Für jeden Task, der in JIRA automatisch angelegt und anschließend synchronisiert werden  soll, musst du das „JIRA Projektkürzel“ in der gleichnamigen Spalte der HQ-Projektplanung eintragen

Jira_Projektplan_mit_Pfeil.png

Von nun an werden alle Änderungen in der HQ Projektplanung zu JIRA synchronisiert, daher werden neue Tickets angelegt und bestehende verändert. Das selbe gilt auch für die Änderungen, die in JIRA erfolgen. Der Sync findet normalerweise mehrmals pro Stunde statt.

2. Verschiedene JIRA-Ticketdaten werden mit "Meine Aufgaben" in HQ synchronisiert (in beide Richtungen)

Bei dieser Funktion werden folgende Felder zwischen JIRA-Tickets und meinen Aufgaben synchronisiert:

  • JIRA <-> HQ
  • Tickets <-> Meine Aufgaben
  • Fälligkeitsdatum <-> Deadline
  • Ursprüngliche Schätzung <-> Soll(in PT)
  • Zusammenfassung <-> Beschreibung der Aufgaben
  • Bearbeiter <-> Verantwortlicher
  • Status <-> Fortschritt

3. Arbeitsprotokolle aus JIRA-Tickets werden mit "Meine Reportings" in HQ synchronisiert (nur von JIRA nach HQ)

Bei dieser Funktion werden folgende Daten synchronisiert:

  • JIRA -> HQ
  • Arbeitsprotokolle -> Reportings
  • Projektname -> Projekt
  • Ticketname -> Task
  • Benötigte Zeit -> Dauer
  • Arbeitsbeschreibung -> Beschreibung des Reportings
  • Startdatum -> Startzeit

Dazu müssen folgende Anforderungen erfüllt sein:

1. Zur Konfiguration der Schnittstelle benötigt HQ folgende Informationen:

  • URL der JIRA-Installation
  • Statusnamen aller Arbeitsabläufe in JIRA (z. B. „Offen“, „In Arbeit“, „Erledigt“, „Erneut
      geöffnet“). Dazu ist außerdem anzugeben, welchem Fortschritt in Prozent (0%, 50% oder
      100%) die einzelnen Statusnamen entsprechen sollen
  • Tickettypen im System

2. Außerdem können Sie sich für eins von zwei Berechtigungsmodellen entscheiden:

  • "BasicAuth“: Dabei erhalten alle Benutzer, die in HQ Daten anlegen, ein und dieselbe
      Rechtestufe in JIRA. (Empfohlen)
  • „OAuth“: Jeder Benutzer nutzt seine individuellen Rechte zur Synchronisation mit JIRA.
      Zu den Berechtigungsmodellen kannst du hier mehr erfahren.

Abhängig davon benötigt HQ zusätzlich folgende Informationen / müssen folgende Elemente eingerichtet werden:

  • Basic Auth
    • Token das unter folgendem Link generiert werden kann: Zum Token (funktioniert nur wenn du in dein Jira eingeloggt bist)
    • E-Mail Adresse eines Jira Benutzers mit Lese- und Schreibrechten für alle Projekte die bearbeitet werden sollen
    • Die E-Mail Adresse der Benutzer die in HQ verwendet wird, muss identisch mit der E-Mail Adresse die in Jira verwendet wird sein. 
      • Wichtig ist, dass das Setting "Sichtbarkeit der Benutzer-E-Mail" aktiviert ist und nicht auf "ausgeblendet" stehht. (Unter "Jira-Einstellungen" / "Allgemeines Konfiguration")
  • OAuth
    • Den Consumer Key aus JIRA (OAuth)
    • Die E-Mail Adresse der Benutzer die in HQ verwendet wird, muss identisch mit der E-Mail Adresse die in Jira verwendet wird sein. 
      • Wichtig ist, dass das Setting "Sichtbarkeit der Benutzer-E-Mail" aktiviert ist und nicht auf "ausgeblendet" steht. (Unter "Jira-Einstellungen" / "Allgemeines Konfiguration")
 

Leider gibt es eine Einschränkung bei allen Funktionen, da HQ keine Daten aus JIRA PLugins abrufen kann. Daher müssen alle Daten in Feldern eingegeben werden, die in der standardisierten JIRA Installation vorhanden sind.

JIRA Synchronisations-Modi

Es gibt grundsätzlich zwei Modi mit denen synchronisiert werden kann: Entweder HQ ist das führende System oder JIRA ist das führende System. Und es kann nur einer dieser beiden Modi aktiviert sein. Hierbei ist zu beachten, dass beim Jira führendem Modus die Synchronisation der Subtasks nicht funktioniert.

Mehr zu den verschiedenen Synchronisations-Modi kannst du Hier erfahren. 

Konfiguration für Schritte 1-3

Um die Funktionen 1-3 freizuschalten musst du zunächst in die Einstellungen in Jira gehen, wo du dann den Reiter Vorgänge auswählst.

Unter Vorgänge musst du nun in der linken Leiste auf "Bildschirmmasken" klicken. Danach klickst du rechts bei "Default Screen" auf konfigurieren.

Dort musst du dann die folgenden Felder hinterlegen:

  • Summary
  • Description
  • Assignee
  • Time Tracking
  • Due Date
  • Reporter

Bild_02.08.19_um_17.49.jpg

 

Konfiguration für JIRA OAuth

Wenn du als Authentifizierungsmethode in deinem JIRA OAuth nutzen möchtest, müssen die folgenden Schritte durchgeführt werden. Danach kann jeder Nutzer in deinem HQ seinen eigenen JIRA-Account nutzen, um Tickets etc. zu synchronisieren.

Zunächst müsst du in deinem JIRA einen Application Link hinzufügen. Dazu gehst du in den Adminbereich in JIRA und gehst dann links auf den Reiter "Application Links" unter Integrations.

Bild_02.08.19_um_15.43.jpg


Anschließend musst du den Hostnamen des Systems eingeben, also die URL deines HQs., bestehend aus: deineFirma,hqlabs.de, und dann auf "Create new link" klicken. Im nächsten Fenster musst du dann einmal die Warnung ignorieren und auf "Continue" klicken.

Im nächsten Fenster gibst du unter "Application Name" "HQSB" ein und klickst auf "Continue". Danach musst du dann im neuen Fenster unter "Incomming Authentication" einen beliebigen "Consumer Key", z.B. hqsb, festlegen und diesen dem Support-Team von HQ mitteilen. Zudem musst du noch die Felder "Consumer Name" und "Description" ausfüllen. Den Public Key schicken wir dir dann zu, sobald wir von dir den Consumer Key bekommen haben.

Wie erfolgt die Authentifizierung?

HQ unterstützt zwei Möglichkeiten der Authentifizierung: Basic Auth und OAuth. Eines der beiden Verfahren muss für die Synchronisation verwendet werden.

Basic Auth:

Bei Basic Auth wird der Benutzername und das Passwort an den Server gesendet. Hierfür muss dein JIRA Administrator uns einen Benutzer zur Verfügung stellen, der Rechte auf die Projekte hat, mit denen HQ die Synchronisation durchführen soll.

OAuth:

Bei OAuth verwendet das HQ das JIRA Konto des jeweiligen Nutzers. Hierfür wird jeder HQ Nutzer einmal mit seinem JIRA Nutzer verknüpft. Das HQ kann dann in JIRA nur die Aktionen durchführen, für die du auch berechtigt bist.

Alle anzeigen...

Exchange

Was wird über Microsoft Exchange synchronisiert?

Termine

In HQ gibt es die Möglichkeit, Termine für Nutzer zu erstellen. Wenn die Exchange-Synchronisation aktiviert ist, werden deine Termine an dein Kalenderprogramm wie z.B. Microsoft Outlook oder Apple Kalender übertragen. Auch anders herum werden Termine, die du über Einladungen in Exchange erhältst oder versendest, in HQ angezeigt. Die Schnittstelle hilft dir dabei Zeiten, Teilnehmer und eventuelle Räume von Termine zwischen Exchange- und HQ-Terminen synchron zu halten.

In HQ kann festgelegt werden, ob diese Synchronisation für alle Nutzer aktiviert sein soll. Außerdem kann für jeden Nutzer eingestellt werden, in welche Richtung die Termine übertragen werden sollen.

Die Schnittstelle von Exchange, die wir verwenden, versendet automatisch, ohne unser zutun, Nachrichten zu jeder Änderung. Eine Zu- oder Absage ist, im Sinne der Schnittstelle, ebenfalls eine Änderung. 

Urlaub kann nicht synchronisiert werden, da die User sonst die Möglichkeit hätten, bereits angenommenen Urlaub in Outlook zu ändern.

Synchronisierte Felder:

Exchange - HQ:
Subject <- Name
Body <- Beschreibung
Location - Ort
Start - Start
End - Ende
Private - Privater Termin

Vorsicht: Du kannst auch wiederkehrende Termine synchronisieren. Folgende wiederkehrenden Termine werden unterstützt: tägliche, wöchentliche, monatliche und jährliche. Hierbei unterstützt das HQ jedoch nur eine Synchronisation von Terminen mit einem angegebenen Enddatum, bzw. ohne Enddatum. Es ist nicht möglich, ein Ende nach x-Wiederholungen einzustellen.

Aufgaben

Aus Projekten oder Workflows in HQ entstehen häufig Aufgaben für die Benutzer, manchmal auch mit einer Deadline. Diese Aufgaben können auch über Exchange mit Clients wie bspw. Microsoft Outlook oder Apple Erinnerungenübertragen werden. Wird die Aufgabe in dem jeweiligen Client abgehakt, wird diese Information auch an HQ übertragen.

Synchronisierte Felder: 

Exchange - HQ:
Subject <- Name
Body <- Beschreibung
Start - Start
DueDate - Ende
TotalWork - Soll
Importance - Priorität
CompleteDate - Fertig
PercentComplete - Fortschritt

Kontakte

Die Kontaktdaten der Ansprechpartner im HQ lassen sich mit der Exchange-Synchronisation ganz einfach in einem Mail-Client oder auf dem Smartphone verfügbar machen. Änderungen der Kontakte werden dabei in beide Richtungen synchronisiert. Die folgenden Kontaktdaten werden zwischen HQ und Exchange synchronisiert:

HQ
Exchange
Vorname GivenName
Nachname Surname
Position JobTitle
Kundenname CompanyName
Telefon Festnetz BusinessPhone
Telefon Handy MobilePhone
Fax Fax
Email EmailAddress1
Private Adresse PhysicalAddressHome
Geschäftliche Adresse PhysicalAddressBusiness
Website BusinessHomePage

Tipp

Kontakte des Typs "Interessent" werden nicht synchronisiert. Exchange akzeptiert keine Kontakte ohne E-Mail-Adresse. Ein Ansprechpartner ohne E-Mail-Adresse bekommt von HQ deshalb eine Adresse in der Form Vorname.Nachname@nomail.de, damit dieser trotzdem synchronisiert werden können.

Achtung: Wenn das Setting "Sync der globalen Kontakte deaktivieren" aktiv ist, werden nur Kontakte gesync die Ansprechpartner eines Unternehmens sind bei dem der Benutzer als Verantwortlicher hinterlegt ist oder im Projektteam eines Projekts in welchem das Unternehmen Kunde ist. 

 

 

Wie richte ich die Schnittstelle zu Exchange ein?

Grundsätzlich kann die Schnittstelle zum Exchange nur von uns eingerichtet werden. Zur Vorbereitung befolgt Ihr die folgenden Schritte und wendet euch anschließend an uns:
 
1. Ihr legt einen HQ-Sync User in eurem Exchange an. 
2. Ihr legt eine Administratorenrolle in Exchange an. 
3. Der Rolle weist ihr die “ApplicationImpersonation”-Role zu.
 
Anleitung: 
Der HQ-Nutzer muss die Exchange-Standardrolle “ApplicationImpersonation” besitzen. Im Admin-Center von Exchange (erreichbar unter Administrator-> Administrator Exchange) könnt ihr Administratorenrollen anlegen und verwalten. Im beigefügten Screenshot ist zu sehen, welche Einstellungen nötig sind.
  
Anschließend sendet Ihr diese Zugangsdaten (Benutzername und Passwort sowie die genaue EWS URL, unter der euer Exchange erreichbar ist) an euren Onboarding Specialist oder an unseren Support unter support@hellohq.io.
 
Sobald wir die Zugangsdaten des HQ-Exchangenutzers haben, können wir den Sync einschalten. Dann müsst ihr uns nur noch mitteilen für welche Nutzer wir aktivieren sollen (gilt auch für die Zukunft für neue Nutzer).
 
Exchangeeinrichtung.png

Kann ich die Exchange-Synchronisation für Subsysteme anpassen?

Wenn man die Exchange-Synchronisation mit mehreren Subsystemen nutzen möchte, werden standardmäßig die Kontakte aller Unternehmen in dem Ordner "Globale Kontakte" synchronisiert.

Da man bei Subsystemen die Unternehmen eventuell stark trennen möchte, haben wir ein System-Setting entwickelt, bei dem nur "Meine Kontakte" zwischen HQ und Exchange synchronisiert werden. Dies verhindert, dass alle Kontakte zwischen verschiedenen Subsystemen synchronisiert werden und muss einmal von uns für euer HQ eingestellt werden!

Wenn du dieses Setting aktiviert haben möchtest, wende dich gern an unseren Support unter support@hellohq.io.

Was sind die Bedingungen, damit ein Kontakt unter "Meine HQ Kontakte" erscheint?

Bei der Exchange-Synchronisation der Kontakte aus dem HQ unterscheiden wir zwischen zwei Ordnern:

  • HQ Globale Kontakte
  • HQ Meine Kontakte

Grundsätzlich werden alle Kontakte im HQ in den Ordner "HQ Globale Kontakte" synchronisiert. Ausgenommen davon sind Kontakte mit den folgenden Eigenschaften (Achtung: Dies ist User spezifisch) die in den Ordner "HQ Meine Kontakte" synchronisiert werden. Diese Kontakte tauchen im Order "HQ Globale KOntakte" nicht mehr auf.

  • Kontakte die Ansprechpartners eines Unternehmens sind, bei dem der Benutzer als Verantwortlich hinterlegt ist
  • Kontakte die als Ansprechpartner in einem Projekt hinterlegt sind, in dem Benutzer als Teammitglied hinterlegt ist.
  • Kontakte die einem Lead zugeordnet sind, in dem der Benutzer als Verantwortlich hinterlegt ist.

Der Sync des Ordners "HQ Globale Kontakte kann auch komplett deaktiviert werden.

Achtung: Kontakte des Typs "Interessent" werden nicht synchronisiert. Exchange akzeptiert keine Kontakte ohne E-Mail-Adresse. Ein Ansprechpartner ohne E-Mail-Adresse bekommt von HQ deshalb eine Adresse in der Form Vorname.Nachname@nomail.de, damit dieser trotzdem synchronisiert werden können.

Per PowerShell mit eurem Exchange Online verbinden

Du hast die Möglichkeit dich per PowerShell mit eurem Exchange Online zu verbinden. Dafür müsst du zuerst das Ausführen von Skripts auf deinem lokalen Computer aktivieren und kannst dann die unten aufgeführten Befehle ausführen.

 

Einmalig das Ausführen von Skripts aktivieren
Bevor man sich zum ersten Mal mit dem Exchange verbindet, muss man einmal das Ausführen von Skripts für den Rechner aktivieren. Das muss
man nur einmal je Computer tun. Öffne dazu PowerShell als Admin und führ folgenden Befehl aus:

 

Set-ExecutionPolicy RemoteSigned


(In PowerShell kann man Code einfügen, indem man einfach in das offene Fenster mit der rechten Maustaste klickt)

 

Mit dem Exchange Online verbinden

1. Öffne auf dem lokalen Computer Windows PowerShell, und führe den folgenden Befehl
aus:

 

$UserCredential = Get-Credential

 

2. Gib im Dialogfenster Bei Windows PowerShell anmelden deinen Office 365-Benutzernamen und dein Kennwort ein, und klick dann auf "OK".

 Führe dann folgenden Befehl aus: 

 

$Session = New-PSSession -ConfigurationName Microsoft.Exchange
-ConnectionUri https://outlook.office365.com/powershell-liveid/
-Credential $UserCredential -Authentication Basic -AllowRedirection

 

3. Im nächsten Schritt kannst du schließlich diesen Befehl ausführen:

 

Import-PSSession $Session

 

Nach dem Einrichten der Verbindung: 

Stelle sicher, dass die Remote-Sitzung getrennt wird, wenn alle Aufgaben erledigt sind. Wenn du nur das PowerShell-Fenster schließt, ohne die Sitzung zu trennen, kann es sein, dass du alle PowerShell Remotesitzungen verbrauchst, die dir zur Verfügung stehen. Dann müsstest du warten, bis deine Sitzung abgelaufen sind. Dazu kannst du diesen Befehl nutzen:

Remove-PSSession $Session

Alle anzeigen...

API

Wo finde ich Eure API?

Am besten besuchst Du unser Developer-Portal. Hier findest Du neben unserem Developer Guide auch unsere REST API Documentation.

Alle anzeigen...

WebDAV

Wie funktioniert WebDAV?

Die HQ-Laufwerk-Integration basiert auf dem WebDAV-Standard und ermöglicht dir die Nutzung eines Cloud-basierten, zentralen Dateisystems ohne Web-Oberfläche auf dem du gemeinsam von überall zugreifen und arbeiten kannst.

Mit der Einrichtung von WebDAV wird ein Laufwerk auf deinem Computer hinzugefügt, das sich über deine Benutzerkennung und deine HQ-Web-URL (https://XYZ.helloHQ.io) mit unseren Servern verbindet. In diesem Laufwerk findest du alle für dich relevanten Dateien, die auch in der Web-Umgebung vom HQ zu finden sind bequem von deinem Desktop aus. 

Auch mittels des WebDAV verfügst du über die gleichen Sicherheitsvorkehrungen, die du aus dem HQ bereits kennst, wie die verschlüsselte Datenverbindung zu unseren Servern bzw. deiner lokalen Installation mittels SSL sowie die Autorisierung mit deinen persönlichen Nutzerdaten. Die Dateien werden selbstverständlich ebenfalls versioniert und sind in allen Backups enthalten.

Wie konfiguriere ich die WebDAV Schnittstelle? 

In den meisten Betriebssystemen sind keine zusätzlichen Programme notwendig um das HQ-Laufwerk auf deinem Computer einzurichten. Durch den offenen Standard sind die Betriebssysteme fähig mit wenigen Klicks eine Verbindung herzustellen, die dauerhaft auf deinem Computer angezeigt wird. Nachfolgend findest du eine Schritt-für-Schritt-Anleitung zur Einrichtung für verschiedene Betriebssysteme.

Windows 10

Klicke auf die Windows-Taste und "E" um den Explorer zu öffnen und dort in der linken Menüleiste auf "Dieser PC". Folgendes Fenster siehst du nun:

Klicke mit der rechten Maustaste auf eine freie Fläche neben den angezeigten Laufwerken und wähle den Menüpunkt „Netzwerkadresse hinzufügen“ aus.

Klicke in dem sich öffnenden Fenster auf „Weiter“. Wähle dann „Eine benutzerdefinierte Netzwerkadresse auswählen“ aus und klicke wieder auf „Weiter“.
Gebe in das Feld „Internet- oder Netzwerkadresse“ Eure unternehmensweite HQLabs-URL ein (https://UNTERNEHMENS-KÜRZEL.hqlabs.de).

Eine Verbindung wird hergestellt und ein Fester zum Eingeben deiner Benutzerkennung erscheint. Gebe hier wie gewohnt Deine persönlichen Login-Daten ein, klicke auf „Kennwort speichern“ falls du dein Kennwort nicht bei jedem Zugriff neu eingeben möchtest und klicke dann auf „OK“. Abschließend kannst du dem Laufwerk einen individuellen Namen geben.


Das HQLaufwerk wird dann automatisch zu Deinen Laufwerken hinzugefügt.

 

Windows 7 

Klicke auf „Start“  „Computer“.
Klicke mit der rechten Maustaste auf eine freie Fläche neben den angezeigten Laufwerken und wähle den Menüpunkt „Netzwerkadresse hinzufügen“ aus.

 

Klicke in dem sich öffnenden Fenster auf „Weiter“. Wähle dann „Eine benutzerdefinierte Netzwerkadresse auswählen“ aus und klicke dann erneut auf „Weiter“.
Gebe in das Feld „Internet- oder Netzwerkadresse“ Ihre unternehmensweite HQLabs-URL ein (https://UNTERNEHMENS-KÜRZEL.hqlabs.de).

 

Tipp

Vergiss dabei nicht das „s“ nach dem http um eine sichere Verbindung herzustellen!

  

Eine Verbindung wird hergestellt und ein Fester zum Eingeben deiner Benutzerkennung erscheint. Geben Sie hier wie gewohnt Ihre persönlichen Login-Daten ein, klicke auf „Kennwort speichern“ falls du dein Kennwort nicht bei jedem Zugriff neu eingeben möchtest und klicke dann auf „OK“. Abschließend kannst du dem Laufwerk einen individuellen Namen geben.
Das HQLaufwerk wird dann automatisch zu Ihren Laufwerken hinzugefügt.

 
 

Max OS X

Wähle den Finder aus oder klicke auf eine freie Fläche auf dem Schreibtisch (In der Programmzeile sollte oben-links jetzt Finder stehen).
Wähle „Gehe zu“ aus und klicke in dem Menü ganz unten auf „Mit Server verbinden...“

 

Gebe in das Feld „Serveradresse“ deine unternehmensweite HQLabs-URL ein (https://UNTERNEHMENS-KÜRZEL.hqlabs.de).

Klicke auf das „+“-Symbol um später erneut auf das Laufwerk zugreifen zu können, ohne die Serveradresse erneut eingeben zu müssen. Klicke danach auf "Verbinden“.

 

Eine Verbindung wird hergestellt und ein Fester zum Eingeben deiner Benutzerkennung erscheint. Gebe hier wie gewohnt deine persönlichen Login-Daten ein, klicke auf „Kennwort im Schlüsselbund sichern“ falls du dein Kennwort nicht bei jedem Zugriff erneut eingeben möchtest und klicke dann auf „OK“.
Das HQ-Laufwerk wird dann automatisch zu deinen Laufwerken im Finder links in der Leiste in der Kategorie „Freigaben“ hinzugefügt.

iOS 

Das iOS unterstützt keine native Verbindung zu dem HQ-Laufwerk, da es keine zentrale Dateiverwaltung auf den Endgeräten gibt. Es ist allerdings möglich mittels verschiedener Apps auf das
HQ-Laufwerk zuzugreifen, wie beispielsweise der GoodReader® (http://www.goodiware.com/goodreader.html), der sich besonders gut für die Verwaltung und Betrachtung von einer Vielzahl unterschiedlicher Dateitypen eignet. Den GoodReader® erhältst du im Apple App-Store.

 

Nach dem Download des GoodReaders® auf deinem iOS-Gerät öffne die Applikation.
Klicke auf „Verbinden“, dann auf „Server“ und wähle unter „Neue Verbindung“ den „WebDAV Server“ aus.

 

Gebe in das Feld „Url-Adresse“ deine unternehmensweite HQLabs-URL ein (https://UNTERNEHMENS-KÜRZEL.helloHQ.io).

Gebe bei „Benutzername“ und „Passwort“ deine persönliche Benutzerkennung ein. Bei „Titel“ kann optional ein individueller Name des Laufwerkes vergeben werden.
Die „Domain“ kannst du leer lassen. Tippe abschließend oben rechts auf die Schaltfläche „Add“.
Das HQ-Laufwerk wurde nun angelegt und du kannst in das Datei-System gehen und verschiedene Dateien herunterladen und betrachten.

Wie erfolgt die Versionierung?

Wird eine Datei überschrieben bzw. bearbeitet, so wird die alte Datei nicht gelöscht, sondern es wird eine neue Version angelegt, auch wenn dein Datei-Explorer dich auf das Überschreiben hinweist. Du kannst über die Web-Oberfläche vom HQ jederzeit zu alten Versionen zurückgehen, sie wiederherstellen oder bei Bedarf auch vollständig entfernen.

Das HQ-Laufwerk zeigt immer die neuste Version an. Für ältere Versionen muss die Web-Oberfläche verwendet werden.

Wird eine ältere Version wiederhergestellt, so wird diese Datei automatisch als neuste Version im HQ-Laufwerk angezeigt.

Wie lösche ich ein Laufwerk?

Im Prinzip kann mein kein Laufwerk löschen, sondern höchstens die Verknüpfung.

Wird eine Datei im HQ-Laufwerk gelöscht, so verschwindet sie in der Ansicht des HQLaufwerks. Genau wie im Falle des 'Papierkorbs' in deinem gewöhnlichen Dateisystem wird sie faktisch jedoch nicht gelöscht. Im Web-Interface vom HQ ist die gelöschte Datei noch sichtbar und als 'zum Löschen vorgemerkt' markiert. Hier kann sie bei Bedarf wiederhergestellt, archiviert oder final entfernt werden.

Du kannst zum Bereinigen deiner Dateiablage jeder Zeit sämtliche zum Löschen vorgemerkte Dateien und alte Versionen unter dem Menü-Button „Bereinigen“ entfernen.

 

 

Warum sagt mir WebDav das die Datei zu groß zum download ist?

Unter Windows gibt es ein Limit wie groß eine Datei sein darf die per WebDav heruntergeladen werden kann. Oft ist dieses als Standard bei 50MB eingestellt. Du kannst dies jedoch anpassen indem Du die folgenden Schritte ausführst:

ACHTUNG: Bitte spreche diesen Schritt zunächst mit deinem Administrator ab, da du hier direkt in der Windows Registry arbeitest!

  1. Klicke auf Start
  2. Tippe "Regedit" ein und öffne die Anwendung
  3. Dort musst du dem folgenden Pfad folgen "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters"
  4. Hier machst du einen Rechtsklick auf "FileSizeLimitInBytes und klickst "Ändern"
  5. Klicke auf Dezimal
  6. Trage den Wert 4294967295 ein.
  7. Starte deinen PC neu

Nun kannst du Dateien von bis zu 4GB herunterladen.

Alle anzeigen...

LDAP (Active Directory)

Ist es möglich das HQ an unsere Active Directory (LDAP) anzubinden?

Die Anbindung an die Active Directory deines Unternehmens ist möglich. Zur Einrichtung im HQ werden die folgenden Daten benötigt:

Name Beschreibung
   
Adresse des AD Hostadresse des AD (kann auch eine IP sein)
   
Login User Der User der für den Sync verwendet werden kann. Dies kann ein "Full Qualified" User sein, je nach System aber auch ein einfach "domain\user".
   
Passwort Das Passwort für den Sync-User
   
Verschlüsselung per SSL Ja oder Nein
   
Protokoll Standard oder OpenLDAP
   
Authentication Typ "Negotiate" oder "Basic"
   
Filter für die AD-User-Synchronisation Der Filter aus dem alle Benutzer in das HQ importiert werden.
   
Group Filter Statement Der vollständige Filter für die Gruppen, die zu HQ übertragen werden sollen. (Pfad in der AD)
   
Root Distinguished Name Pfad auf dem in der AD zu den zu synchronisierenden Benutzern.
   
User Domain Wenn der Sync-Benutzer in einer Domain ist, kann es sein das die Domain explizit angegeben werden muss, da der Benutzer ansonsten nicht gefunden wird.

 

 

Achtung: Die Synchronisation per LDAP ist erst ab dem Professional Plan möglich.

Kann ich Benutzer nachträglich mit der Active Directory verknüpfen?

Allgemeines

Generell werden AD-User als neue Benutzer in HQ angelegt. Damit werden die Benutzer, die im Vorfeld beispielsweise für Tests angelegt wurden, redundant. 
Wenn bereits produktiv gearbeitet wird, ist das ungünstig, weil relevante Daten (Kunden, Projekte, Aufgaben, Belege) nach dem Import aus AD mit dem "falschen" HQ-Benutzer verknüpft sind.
Es sollte also im Vorfeld geklärt werden, inwieweit vor AD-Anbindung produktive Daten angelegt werden sollen. Eine Korrektur der Daten im Nachhinein ist natürlich möglich, allerdings in der Regel umständlich. Deshalb empfehlen wir, bestehende HQ-Nutzer mit den zu importierenden AD-Nutzern zu verknüpfen. 

Wie können wir die Benutzer verknüpfen?

Die aus AD importieren User erhalten in HQ einen Eintrag zur Identifikation. Dafür kann ein eigens definiertes Datenfeld mit dem Namen "Active Directory Unique Key" am Benutzer an (Admin / Standardwerte / Datenfelder Benutzer) angelegt werden. Das Feld wird in jedem Fall benötigt, auch wenn keine Benutzer verknüpft werden sollen. In dieses Feld kopiert ihr den Wert des Attributs "objectSid" aus AD oder - wenn diese nicht existiert - aus dem Attribut "EntryUUID" aus der entsprechenden "directory". 

Voraussetzungen

  • Im HQ muss das Feld "Active Directory Unique Key" für Benutzer angelegt werden (siehe oben, Admin / Standardwerte / Datenfelder Benutzer). 
  • Die AD-Gruppe, die importiert werden soll, muss das Attribut "displayname" oder "description" enthalten. Dies wird der Klarname, den die HQ-Gruppe enthält. Wenn beide Felder nicht vorhanden sind wird das Feld "cn" verwendet, das häufig aber keinen echten Klarnamen beinhaltet.
  • Die AD-User, die importiert werden sollen, müssen folgende Felder ausgefüllt enthalten: "samaccountname" oder "uid" sowie "mail". Um sinnvolle Daten zu erhalten, genauso bitte "givenName", "sn" und "telephoneNumber" pflegen. "samaccountname" oder "uid" sind der neue Benutzername im HQ.
  • Sollen die Nutzer auch den gesyncten Gruppen zugeordnet werden, so müssen die User eine Property "memberOf" oder "member" besitzen in denen der full-qualified name der Gruppen steht. Die Gruppen müssen auch über das Verzeichnis synchronisiert worden sein, damit eine Zuordnung möglich ist.

Kann ich auch Benutzer zum HQ hinzufügen, die nicht zu unserem Active Directory (LDAP) gehören?

Wenn du für euer HQ die Anbindung zu LDAP eingerichtet hast, kannst du trotzdem weiterhin Mitarbeiter einladen, die nicht zu eurem LDAP gehören.

Dafür kannst du einfach den hier beschriebenen Weg folgen!

Alle anzeigen...